# dagster-feedback

Matt Clarke

03/13/2023, 2:50 PM
I'm trying to install black as a dev dependency and am running in to the following:
Copy code
❯ poetry add --group dev black
Using version ^23.1.0 for black

Updating dependencies
Resolving dependencies... (0.2s)

Because no versions of black match >23.1.0,<24.0.0
 and black (23.1.0) depends on packaging (>=22.0), black (>=23.1.0,<24.0.0) requires packaging (>=22.0).
And because dagster-cloud (1.2.1) depends on dagster-cloud-cli (1.2.1) which depends on packaging (>=20.9,<22), black (>=23.1.0,<24.0.0) is incompatible with dagster-cloud (1.2.1).
So, because ***** depends on both dagster-cloud (1.2.1) and black (^23.1.0), version solving failed.
I can get around it by pinning to the final 22.* release of black, but am wondering if there is any reason that the packaging module in
needs to be pinned to
🤖 1


03/13/2023, 10:35 PM
this was because packaging v22 has build compatibility issues with dbt
but lemme try unpinning it today to see if it’s still a legit issue today
👍 1
Hi! We removed the <22 pin in 1.2.2 (which was released today)