Sometimes, the materialize button for partitioned ...
# ask-community
Sometimes, the materialize button for partitioned assets becomes disabled Hovering the cursor over it displays this message: "Disabled by your administrator".
Hi Daniel - this seems like something we should prioritize fixing but i'm having some trouble reproducing it - any more you can share about steps to reproduce?
Hey! I'll try to upgrade again and see if I can reproduce this. I can't do it right now tho, maybe in like 6 hours. A weird bug. Non-partitioned assets worked without a problem.
I tried with this simple partitioned asset and was able to materialize it on 1.2.4, so there must be something more subtle going on
Copy code
from dagster import DailyPartitionsDefinition, asset

def my_daily_partitioned_asset(context) -> None:
Yeah I also just got this error again with 1.2.3. I'll change the original message. It may have something to do with my setup. I'm running dagster in a "sandbox" k8s that's not very stable (I observed the UI not loading the asset lineage for example because of some connection issues). Perhaps you shouldn't spend your time on this right now. Sorry for the misleading issue!
All good - yeah i wonder if it could be something with the default state in the UI failing closed if there's an issue fetching some data?
I observed the same thing yesterday. Also OSS hosting in k8s. Symptoms: • Wipe materializations button greyed out • Materialize button said "Disabled by your administrator" After refreshing the page both buttons became available. I believe my user-deployment and possibly my dagster daemon as well were being moved from one node to another by k8s and were briefly unavailable around this time.
Tried reproducing just now by manually scaling the user deployment and daemon to 0, but no luck unfortunately.