Anyone here have any experience using Pycharm for ...
# ask-community
Anyone here have any experience using Pycharm for debugging with dagster? I have a project where I am able to run
poetry run python -m dagit
in my terminal and it works correctly, but when I try to run from Pycharm using the attached configuration and I receive the following error:
Copy code
Process finished with exit code 134 (interrupted by signal 6: SIGABRT)
In addition, I seem to get this error when I run either
dagster dev
poetry run python -m dagit
from within pycharm.
I tried switching over to VSCode and this same error occurred. For context I am running on an Intel Macbook on OSX Ventura. This appears to not be an IDE specific error, although I'm not sure why it does not happen when running in the terminal.
In case anyone else runs into this: I ended up needing to update my computer. The above Pycharm configurations worked perfectly, but it appears there was an Xcode update that fixed an issue that was preventing the debugger from interacting with the process correctly
thank you box 1