https://dagster.io/ logo
#ask-community
Title
# ask-community
j

Jon C

05/10/2023, 10:28 PM
Hi All, I have dagster installed through helm on an EKS cluster. When ever I run a job I get the error shown. Any idea why this happens? Appreciate any help
🤖 1
d

daniel

05/10/2023, 10:52 PM
Hi Jon - you may need to upgrade the dagster version that’s being used by your job code to match the version that’s being used by the helm chart
j

Jon C

05/11/2023, 2:13 AM
Thanks for your response. I went ahead and updated everything to match. The Dagster app version
1.3.3
. And then for the job code I also updated the dependencies. I am still getting the same error. requirements.txt:
Copy code
dagster==1.3.3
dagster-graphql==1.3.3
dagit==1.3.3
dagster-postgres==0.19.3
dagster-dbt==0.19.3
dagster-pandas==0.19.3
dagster-docker==0.19.3
dagster-airbyte==0.19.3
dagster-shell==0.19.3
dbt-core==1.5.0
dbt-postgres==1.5.0
dbt-databricks==1.5.1
d

daniel

05/11/2023, 2:14 AM
Would it be possible to run 'pip freeze' in your job image?
Copy code
Received unexpected config entries "['dequeue_num_workers', 'dequeue_use_threads']" at the root. Expected: "['dequeue_interval_seconds', 'max_concurrent_runs', 'tag_concurrency_limits']."
The config entries that it mentions there that are missing are definitely present in 1.3.3. - so I just want to be absolutely certain that your job code is running that version
j

Jon C

05/11/2023, 2:16 AM
To make sure I understand this is what you mean? I added that in the dockerfile
d

daniel

05/11/2023, 2:17 AM
I would do something like
docker run <image name> /bin/bash
after building the image
then in the shell, run 'pip freeze'
j

Jon C

05/11/2023, 2:17 AM
oh oh gotcha
trying
Here is the output
Fixed now. I appreciate your help. Solution: I went back and made sure all dependencies were present
3 Views