I think i'm messing something up in my pyproject f...
# ask-community
I think i'm messing something up in my pyproject file, but I'm getting version errors with trying to install both the azure and bigquery plugins. I have these dependencies:
Copy code
python = "==3.10.8"
dagster = "^1.2.4"
dagster-cloud = "^1.2.4"
pex = "==2.1.130"
dagit = "^1.2.4"
pandas = "==1.5.3"
click = "==8.1.3"
sendgrid = "^6.10.0"
dagster-azure = "^0.18.4"
pyarrow = "^11.0.0"
and when trying to
poetry add dagster-gcp dagster-gcp-pandas
I get an error that
Thus, dagster-gcp-pandas (>=0.19.5,<0.20.0) is incompatible with dagster-azure (>=0.18.4,<0.19.0).
. Is dagster-gcp really incompatible with dagster-azure? in dagster-azure's setup, https://github.com/dagster-io/dagster/blob/master/python_modules/libraries/dagster-azure/setup.py, i see its doing something with having the dagster version pinned with an interpolated variable? So maybe there's something I can do with my environment to get this install working?
dagster bot responded by community 1
The versions are incompatible. You either need to update all of your current dagster packages, or if you need to use old versions, install the new packages with a clamp:
poetry add dagster-gcp=^0.18.4 dagster-gcp-pandas=^0.18.4
ahh - I need older versions of the gcp ones? ok, thanks
🎯 1
in general, you should always try to keep your dagster packages at the same version (noting that the main dagster package is 1.x.x, but most libraries are still 0.x.x. you can always see which versions correspond to each other in the changelog)