# ask-community

Angad Singh

07/03/2023, 7:29 AM
hi! trying out dagster and unable to install it properly - using an M2 Mac.
Copy code
(base)  angad@Angads-MacBook-Air  ~/workspace/data  dagster project scaffold --name dagster_data
Traceback (most recent call last):
  File "/Users/angad/miniconda3/bin/dagster", line 5, in <module>
    from dagster.cli import main
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/dagster/", line 72, in exec_module
    base_module = importlib.import_module(
  File "/Users/angad/miniconda3/lib/python3.10/importlib/", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/dagster/_cli/", line 4, in <module>
    from .api import api_cli
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/dagster/_cli/", line 14, in <module>
    from dagster._cli.workspace.cli_target import (
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/dagster/_cli/workspace/", line 1, in <module>
    from .cli_target import (
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/dagster/_cli/workspace/", line 29, in <module>
    from dagster._core.host_representation.code_location import CodeLocation
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/dagster/_core/host_representation/", line 9, in <module>
    from .external import (
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/dagster/_core/host_representation/", line 39, in <module>
    from dagster._core.host_representation.origin import (
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/dagster/_core/host_representation/", line 16, in <module>
    import grpc
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/grpc/", line 22, in <module>
    from grpc import _compression
  File "/Users/angad/miniconda3/lib/python3.10/site-packages/grpc/", line 20, in <module>
    from grpc._cython import cygrpc
ImportError: dlopen(/Users/angad/miniconda3/lib/python3.10/site-packages/grpc/_cython/, 0x0002): symbol not found in flat namespace '_kCFStreamPropertySocketNativeHandle'
Installed dagster using instructions on the documentation
Copy code
pip install dagster dagit --find-links=<>
tried with both python 3.10 and 3.11

Justin Taylor

07/03/2023, 11:50 AM
Have you tried creating a fresh conda environment and using only
conda install
) to install everything?
Alternatively, might be worth trying to use
only if you are not married to conda.

Thomas Monk

07/03/2023, 3:46 PM
A fresh conda env worked for me when installing on my M2 recently, after receiving similar grpc related errors through pip. The only caveat was to install urllib3<2 first, as later versions are currently incompatible with Apple silicon.

Angad Singh

07/04/2023, 6:26 AM
works thanks