Hey All, I'm currently trialling Dagster Cloud Hyb...
# ask-community
Hey All, I'm currently trialling Dagster Cloud Hybrid but I am running into a strange issue with branch deployments. Whenever a new branch is created, a "managed by dagster cloud" agent shows up alongside the K8s branch agent I've deployed. The Dagster agent is preventing me from running code because I get the error (* censored image name)
Copy code
Invalid image us.gcr.io/******************. Only images managed by Dagster Cloud can be used in Serverless deployments
But it's set to a hybrid deployment in the web UI. Is this a bug or have I configured something wrong?
Hey Eric, it looks like you might have first tried using serverless before switching to hybrid?
hey Joe, yeah I did
can you share your org name? I can go in and clean up the serverless resources, there might have been something that went wrong during deactivation
ok @Eric Stegelmeier it should be fixed. Just curious did you quickly switch to hybrid from serverless after creating your account?
trying to figure out how you got into this state
It was a couple of days afterwards. Never did a deployment to serverless though. Read through the docs and the 100gb/day network limit wouldn't have worked for our usecase
gotcha, thats helpful.
What network limit would have worked for your usecase?
I was thinking of the backfills for a certain pipeline where the historical dataset was over 6tb in size. In actual use the backfill might be expected to be over a few days, but with that data size, I guess it's not just the network limit but GCP transfer fees that become an issue. At that point it just seemed it made sense to self manage k8s so we can co-locate compute + storage in GCP and get free data transfer + configurable pod resources
👍 1
Materialization is running now, thanks for your help!