Hi, I recently updatem my dagit package and I am c...
# ask-community
a
Hi, I recently updatem my dagit package and I am constantly getting an error:
pydantic.errors.PydanticImportError:
pydantic:ConstrainedFloat
has been removed in V2.
Is there any quick fix possible?
dagster bot responded by community 2
a
I guess you need to upgrade
pydantic
to v2, but be careful if you use it explicitly somewhere (not just a dagster/dagit dependency), because this is a major release with several breaking changes.
z
Isn't the fix to actually downgrade pydantic? The latest versions of Dagster are actually pinned to
"pydantic != 1.10.7,<2.0.0"
, it's the fact that the version of pydantic is > 2.0 in an environment with Dagster that causes this error
a
Of course, you’re right. @Adam Składanek, I read this backwards.