hey started some weird graphql errors when loadin...
# ask-community
hey started some weird graphql errors when loading runs:
Copy code
Operation name: PipelineRunsRootQuery

Message: Cannot return null for non-nullable field Run.mode.

Path: ["pipelineRunsOrError","results",0,"mode"]

Locations: [{"line":26,"column":3}]
D 1
Hi Eduardo - what version of dagit are you running? And what version is your code?
I am having the same problem. Were you guys able to fix it ? I am using the very last version of dagster: 1.4.7
no, the errors stopped for a while but they actually just came back for some reason i havent updated dagster from my current version, 1.3.6 i was planning to update dagster this week hopefully
This was a bug in 1.3 that I’d expect to be solved by upgrading. @Davi are you certain this same error has appeared since moving to 1.4.7?
@johann I think I found the problem. One of my docker images was using the wrong package version. So even if the others were right, the one having the bad versions was causing this problem.