https://dagster.io/ logo
#ask-ai
Title
# ask-ai
a

Alan Bohannon

02/09/2024, 8:03 PM
@Scout I pip installed dagster-aws and dagster-webserver and got this error:
Copy code
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts. dagster-graphql 1.6.4 requires dagster==1.6.4, but you have dagster 1.6.3 which is incompatible. dagster-webserver 1.6.4 requires dagster==1.6.4, but you have dagster 1.6.3 which is incompatible.
I’m also getting this warning when running dagster dev:
Copy code
UserWarning: Found version mismatch between `dagster` (1.6.3)and `dagster-webserver` (1.6.4) warnings.warn(message)
UserWarning: Found version mismatch between `dagster` (1.6.3)and `dagster-graphql` (1.6.4) warnings.warn(message)
s

Scout

02/09/2024, 8:03 PM
It appears that you are encountering a version mismatch issue between
dagster
,
dagster-webserver
, and
dagster-graphql
. The error message indicates that
dagster-webserver
and
dagster-graphql
both require
dagster
version 1.6.4, but you currently have
dagster
version 1.6.3 installed. To resolve this issue, you should ensure that all your Dagster packages are on the same version. This is important because Dagster libraries are designed to work together when they are on matching versions. The documentation suggests that Dagster libraries will error if version mismatched with the core dagster package. Because of the compatibility layer introduced in dagster 1.5.5, older versions of libraries may not work properly with newer versions of the core package. Here are the steps you can take to fix the version mismatch: 1. Upgrade
dagster
to match the version of
dagster-webserver
and
dagster-graphql
by running:
Copy code
pip install dagster==1.6.4
2. Alternatively, you can upgrade all related packages to their latest compatible versions together to avoid any conflicts. You can do this by running:
Copy code
pip install dagster dagster-webserver dagster-graphql --upgrade
After performing the upgrade, you should no longer see the version mismatch warnings when running Dagster in development mode. If you continue to experience issues, you may want to check for any additional dependencies that could be causing conflicts and ensure they are also on compatible versions.
The error and warnings you're encountering indicate that there is a version mismatch between the installed
dagster
package and the
dagster-webserver
and
dagster-graphql
packages. Specifically,
dagster-webserver
and
dagster-graphql
both require
dagster
version 1.6.4, but you currently have
dagster
version 1.6.3 installed. To resolve this issue, you should align the versions of all related Dagster packages. Here's how you can do it: 1. Upgrade your
dagster
package to version 1.6.4 to match the versions of
dagster-webserver
and
dagster-graphql
. You can do this by running the following command:
Copy code
pip install dagster==1.6.4
2. If you prefer to upgrade all related packages to their latest versions at once, you can use the following command:
Copy code
pip install dagster dagster-webserver dagster-graphql --upgrade
By ensuring that all Dagster packages are on the same version, you should be able to avoid compatibility issues and the associated warnings should no longer appear when you run Dagster in development mode. If you continue to face issues after upgrading, make sure to check for any other dependencies that might be causing conflicts and ensure they are also updated to compatible versions. support dagster 1.3.5 for `dagster-fivet... button Thank you for your feedback!
5 Views