# ask-community

Maxime Kieffer

02/28/2024, 3:55 PM
Hi guys, I have a Dagster pipeline that will perform some ETL tasks for me regularly. Recently, I encountered an issue with runs: ImportError: Pandas requires version '3.1.0' or newer of 'openpyxl' (version '3.0.10' currently installed). This occurred while trying to read an Excel file. So, I assumed that updating the version of the openpyxl package to be above 3.0.10 would solve the problem. I updated my pyproject.lock with this: openpyxl = "^3.1.2" However, I still encounter the same issue. Do you have any ideas on what I might have done wrong and how I could fix this?