https://dagster.io/ logo
#announcements
Title
# announcements
e

Edward Chen

02/04/2021, 11:38 PM
Hi all, another quick question. So I know it’s a configuration issue now but if I could get some tips on where to look next, that’d be great. Problem: I am able to get a list of repositories via GraphQL if I run it locally but when I run it as a docker container, it returns back an empty array. Things I’ve tried/confirmed: • Confirmed what I think is a valid working_directory and relative_path in workspace.yaml • I run both of the curl calls (from GraphQL playground) so nothing changes there. When local, I run it from terminal and when in docker container, i ssh into the container and run the same curl call • Workspace.yml is pretty simple:
Copy code
load_from:
  - python_environment:
      executable_path: /usr/local/bin/python
      target:
        python_file:
          relative_path: /opt/dagster/dags/example/hello_dagster.py
          working_directory: /opt/dagster/dags
The curl call that I do is also pretty simple:
Copy code
curl -v '<http://localhost:3000/graphql>' \
-H 'Accept-Encoding: gzip, deflate, br' \
-H 'Content-Type: application/json' \
-H 'Accept: application/json' \
-H 'Connection: keep-alive' \
-H 'DNT: 1' \
-H 'Origin: <http://localhost:3000>' \
--data-binary '{"query":"query RepositoriesQuery {\n  repositoriesOrError {\n    ... on RepositoryConnection {\n      nodes {\n        name\n        location {\n          name\n        }\n      }\n    }\n  }\n}"}' --compressed
d

daniel

02/05/2021, 12:24 PM
Hi Edward - are there any logs from dagit starting up in the container logs? If the repositories couldn’t load I would expect there to be some kind of error in the logs that helps explain why.
e

Edward Chen

02/05/2021, 5:27 PM
sorry i meant to update this thread last night but I got it working and went straight into the work that this was blocking me on. I don’t think it’s an error, just a misunderstanding on my end. I had put the working_directory to a folder with all my DAGs but it only worked when I put it as the root of the docker container. Otherwise, it would return an empty array. So there wasn’t a failure (Status 200 with empty array), I just didn’t immediately know the working directory is the issue