Hi, Your own example of ‘airline-demo’ does not wo...
# announcements
Hi, Your own example of ‘airline-demo’ does not work as python module installed in virtualenv. PFA ‘airline-demo’ module exist in remote venv but dagit tells it does not exist.
I am not sure if this is a similar cause but I have problem dynamically importing dagster in virtualenv. Essentially I have a module dagtsrer.py that contains call
, where pipeline is a path to dagster pipeline, i.e.
. When I run
poetry run python  dagtsrer.py --path blah/pipeline.py
I get an error
Copy code
import dagster_pandas as dagster_pd
  File "/Users/apple/Library/Caches/pypoetry/virtualenvs/pwmf-qUT5bdGW-py3.7/lib/python3.7/site-packages/dagster_pandas/__init__.py", line 1, in <module>
    from dagster.core.utils import check_dagster_package_version
ModuleNotFoundError: No module named 'dagster.core'; 'dagster' is not a package
This does not happen when I run
from poetry shell. Other third-party packages also seem to import dynamically with no problems. Any suggestions would be most appreciated - thanks in advance!
My fault -
masked the
package during import 😱