Hello Guys, just to address the topics of the time...
# announcements
t
Hello Guys, just to address the topics of the timezone change and let you know how we did it and what is the blockers. We build a docker image with dagster, dagit, ... and our pipeplines:
Copy code
FROM python:3.7.5-slim-stretch

ADD . .

# Set timezone
ENV TZ=Europe/Paris
ENV CRON_TZ=Europe/Paris

RUN apt-get update -yqq && apt-get install -yqq cron gcc git tzdata
You can see we change the timezone in the container to fit with our timezone (and scheduled pipelines are executed at the right hour). It works great, and the timezone is apply at container wide:
Copy code
$ docker exec -it data_pipelines_dagit_1 /bin/bash
root@523fbfca03d1:/tmp# date
Tue Jul 28 10:31:26 CEST 2020
In the UI (dagit), in the run list, overview, scheduled run, it displays the datetime in the correct timezone (no offset) 👌 But in the run logs, there is the UTC offset (date is display in UTC). Seems a known issue -> https://github.com/dagster-io/dagster/issues/1750 Add to that, it could be nice to be able to see the current date in Dagit (in the footer or in instance settings). Let me know if you need more feedback on this (perhaps I could help contribute on an How to section of the documentation to explain how to configure the timezone for dagster) 👌. Just sharing some ❤️ - Great jobs BTW, love Dagster and using it with my team in production!
dagsir 1
❤️ 1
Note: if you use Debian stretch slim, seems you need to specify to cron via an environment variable
CRON_TZ=Europe/Paris
the timezone for the system cron.