Hey guys. Got this error during `pip install dagst...
# announcements
o
Hey guys. Got this error during
pip install dagster
to my current project
Copy code
ERROR: dagster 0.5.5 has requirement pyyaml==4.2b1, but you'll have pyyaml 5.1.1 which is incompatible.
s
Hey Oleg we will take a look at this! We had some problems with pyyaml and docker-compose and made the a dependency constraint, but this might have been overkill. I suspect you can workaround this by uninstalling pyyaml, then running pip install dagster, and then reinstalling the pyyaml version that you expect.
o
Actually, seems dagster was installed, because I can do
import dagster
in repl. Will let you know if something will be broken
s
👍
yeah pip says “ERROR” where “WARNING” is really more accurate
in these cases
note that the root cause of this is that docker-compose enforces this constraint: https://github.com/docker/compose/blob/master/setup.py
either way added https://github.com/dagster-io/dagster/issues/1657 to track. thank you!
o
Great, thanks!