Hi team, I am experiencing some strange behavior ...
# deployment-kubernetes
Hi team, I am experiencing some strange behavior when trying to leverage the “externalConfigMap” setting to set the workspace for dagit. We are dynamically creating user deployments and would like to be able to load them into dagit, and I noticed on a separate thread that this setting was added recently to account for this use case. A screenshot of my dagit configuration is attached, where we point the workspace to an external configmap of "dagster-workspace". When bringing up the dagit/daemon pods, they are now both failing to start while saying they cannot locate the workspace file (see attached error screenshot). If I get the configmaps on the server and describe the dagster-workspace configmap, we can see that it is using the same configuration that worked when filling in the “servers” section of the values.yaml instead of the “externalConfigMap” section. Am I missing some type of volumeMount to get dagit/daemon to recognize the workspace?
Hi Jim - I think it may be expecting the data inside the configmap to be workspace.yaml not workspace-configmap.yaml
Ok, that was the name of the yaml file that I created the configmap with, let me try renaming it
Hi Daniel, changing the filename I created the configmap with worked, now the daemon/dagit are successfully running and detecting our repo containers. Thank you very much for your help, you're the best!
condagster 1