https://dagster.io/ logo
#ask-community
Title
# ask-community
z

Zach

05/31/2022, 9:14 PM
I'm having an issue with getting my Dagit container restarted - not sure exactly what changed, I hadn't done anything to change the dockerfile:
Copy code
dagster_docker_dagit  | Traceback (most recent call last):
dagster_docker_dagit  |   File "/usr/local/bin/dagit", line 5, in <module>
dagster_docker_dagit  |     from dagit.cli import main
dagster_docker_dagit  |   File "/usr/local/lib/python3.9/site-packages/dagit/cli.py", line 21, in <module>
dagster_docker_dagit  |     from .app import create_app_from_workspace_process_context
dagster_docker_dagit  |   File "/usr/local/lib/python3.9/site-packages/dagit/app.py", line 11, in <module>
dagster_docker_dagit  |     from .webserver import DagitWebserver
dagster_docker_dagit  |   File "/usr/local/lib/python3.9/site-packages/dagit/webserver.py", line 7, in <module>
dagster_docker_dagit  |     import nbformat
dagster_docker_dagit  |   File "/usr/local/lib/python3.9/site-packages/nbformat/__init__.py", line 9, in <module>
dagster_docker_dagit  |     from traitlets.log import get_logger
dagster_docker_dagit  |   File "/usr/local/lib/python3.9/site-packages/traitlets/__init__.py", line 5, in <module>
dagster_docker_dagit  |     from ._version import __version__, version_info
dagster_docker_dagit  |   File "/usr/local/lib/python3.9/site-packages/traitlets/_version.py", line 7, in <module>
dagster_docker_dagit  |     assert __version__ == (
the docker compose logs seem to cut off there
🤖 1
r

rex

05/31/2022, 9:14 PM
new traitlets version appeared
z

Zach

05/31/2022, 9:15 PM
ah so do I need to pin traitlets?
👍🏽 1
r

rex

05/31/2022, 9:15 PM
if you pin on your end, it should resolve itself. we’re working on a fix ourselves
z

Zach

05/31/2022, 9:15 PM
awesome, thanks so much
a

Andrew Parsons

05/31/2022, 10:31 PM
I'll echo that I am also having this problem. Which version should I be pinning? I have tried: •
traitlets==5.2.1
traitlets==5.1.1
z

Zach

05/31/2022, 10:31 PM
I had luck with 5.2.0
a

Andrew Parsons

05/31/2022, 10:32 PM
Great, thanks; I will try that next Update: I pinned the following: •
traitlets==5.2.0
nbclient==0.6.3
My previous issues were probably because I wasn't redeploying with my newly-built (i.e. with pinned package versions) Docker image 🙃