https://dagster.io/ logo
#ask-community
Title
# ask-community
j

jasono

05/10/2022, 2:29 PM
Hi, I noticed Launch Run’s input pane auto-populates the
resource values
defined in the repo code but not
ops config_schema
default values also defined in the repo. What’s the reason behind that? Every time the repo is reloaded, having to write the config_schema manually (with lots of curly braces- unlike the yaml style
resources
definition) is less convenient.
y

yuhan

05/10/2022, 7:34 PM
does the “Scaffold missing config” on the bottom left work for you? it scaffold missing config by filling w/ all default values
j

jasono

05/11/2022, 1:07 AM
@yuhan Hmm.. I’m not seeing this scaffolding button. Is this supposed to be under the Launchpad tab?
y

yuhan

05/11/2022, 1:10 AM
yes I think you may need to click on the editor to trigger the config validation - if theres an error, that button would show up
j

jasono

05/11/2022, 1:11 AM
I typed in some random thing and then “Remove Extra Config” button shows up.
Oh… typed in the config almost completely and left the variable value blank, then “Scaffold missing config” finally showed up.
This button could be an always visible one.
Well, unfortunately the scaffolding it gave me resulted in an error, and this time the scaffolding button doesn’t show up.
The scaffold was in a yaml format rather than {ops … }. That’s probably why the editor thinks it was an error.
y

yuhan

05/11/2022, 1:41 AM
Got it - thanks for trying it out and all the context! I think there’s def room for improving the scaffolding experience
@Dagster Bot issue [dagit] launchpad: enrich “Scaffold missing config” functionality
d

Dagster Bot

05/11/2022, 1:42 AM
j

jasono

05/11/2022, 1:54 AM
Thank you!