James Parker

12/13/2021, 6:02 PM
hey friends, having troubles getting dagster to pull an image from a private dockerhub repo…. I have this set in the global section of my config yml
  - name: dhub-ccdevs
which is the same pull secret we use for all of our other k8s deployments, works fine for them, but the user deployment pod is getting this error:
Warning  Failed     26m (x4 over 28m)      kubelet            Failed to pull image "myorg/myrepo:latest": rpc error: code = Unknown desc = Error response from daemon: pull access denied for myorg/myrepo, repository does not exist or may require 'docker login': denied: requested access to the resource is denied
also tried inserting the
key directly into the deployments defn on the same level as the
key and on the same level as the
key. nothing seems to help. can someone confirm that dagster expects this image pull secret in the same format as a typical k8s deployment?


12/13/2021, 6:10 PM
Hey james are you using the Helm chart? You’ll need to specify the
as well, since the Kubernetes user code deployments have a separate service account attached to them. See

James Parker

12/13/2021, 6:10 PM
yes I am
I attempted to add the key to the user deployments section, maybe I put it in the wrong place, let me try again
ah that worked 🙂
just had it in the wrong place before