https://dagster.io/ logo
#ask-community
Title
# ask-community
m

madhurt

06/30/2021, 5:26 PM
Hi guys, I have been able to successfully deploy a dagster pipeline to AWS EKS (Kubernetes) cluster. However, to access the dagit interface, I still run
Copy code
export DAGIT_POD_NAME=$(kubectl get pods --namespace default \
  -l "<http://app.kubernetes.io/name=dagster,app.kubernetes.io/instance=dagster,component=dagit|app.kubernetes.io/name=dagster,app.kubernetes.io/instance=dagster,component=dagit>" \
  -o jsonpath="{.items[0].metadata.name}")
kubectl --namespace default port-forward $DAGIT_POD_NAME 8080:80
To have a permanent address instead, what should be done? Do I create a
service
for it? If yes, what could be the steps? I could appreciate some sense of direction. Do I need to edit
values.yaml
too (that we use in
helm
)?
r

rex

06/30/2021, 5:37 PM
if you’re using the helm chart, a service should already be created for Dagit. I’m assuming that you want a permanent, external address to access Dagit (like dagit.madhurt.com) - you should look into creating an ingress for your service to allow for an external url https://kubernetes.io/docs/concepts/services-networking/ingress/
there’s an ingress that’s available by setting
.Values.ingress.enabled
to True, but you’ll also need some sort of ingress controller in your cluster to get this up and running
m

madhurt

06/30/2021, 6:32 PM
Yes, I am using the helm chart. Thanks, would I also have to change the
.Values.dagit.service.type
to
LoadBalancer
? It’s set to
ClusterIP
by default.
r

rex

06/30/2021, 6:42 PM
I think that depends on what ingress controller you end up using - for example, if you end up using the NGINX Ingress Controller, a service type of
ClusterIP
should be fine.