Hello! I'm testing out the new definitions way of...
# ask-community
Hello! I'm testing out the new definitions way of loading assets/jobs (instead of repositories) in dagster 1.17. However, the jobs don't seem to be loading in Dagit. The assets are loading in dagit, but the job is not loading (on the side bar there would be a "job" tab, also there are no job definitions loaded when I run dagit)
def asset1():
return [1, 2, 3]
def asset2(asset1):
return asset1 + [4]
all_assets_job = define_asset_job(name="all_assets_job")
asset1_job = define_asset_job(name="asset1_job", selection="asset1")
defs = Definitions(
assets=[asset1, asset2],
jobs=[all_assets_job, asset1_job]
I stole the code snippet from the "how to create jobs from software defined assets section of the docs" https://docs.dagster.io/concepts/ops-jobs-graphs/jobs#from-software-defined-assets Am I doing something incorrect with the new API?
Hmm-- are you sure you’re running 1.1.7 of dagit? I just tried that code and I can see the jobs:
ooo 1
let me triple check!
Yeah, 1.17 of dagit, interesting though. If it is runs properly for you something may be afoot in my environment. I'll resetup everything and try again
@sean thanks for taking a look!
Interesting. I have to leave this for now, but I created a new project, used the same code snippet, and ran into the same issue. The job defs don't seem to be picked up. • Windows 10 • Python 3.10 • Dagster 1.1.7 • Dagit 1.1.7 • Using a virtual environment with python -m venv venv • New project scaffolded with dagster project scaffold --name <name> • Command run in root directory: Dagit
hmm I wonder if this is some windows issue, few of our devs run windows machines, let me see if I can have someone test it