I’m using Dagster Cloud Serverless, and I recently...
# dagster-plus
j
I’m using Dagster Cloud Serverless, and I recently tried making a branch deployment which updated the runtime to Python 3.10 in my GitHub Action as shown here, but now my branch deployments are getting the below error message when I try to deploy. Could I get some help figuring out why this won’t deploy? Running the commit locally with dagit (and local Python 3.10 of course) works fine. cc from earlier convo: @Dagster Jarred Thread in #dagster-support
j
Hi Jonathan - can you try clicking redeploy? I don’t see anything obviously wrong in our logs - the code location is indeed up. I wonder if we just timed out too aggressively.
j
Sure thing. I had tried redeploying once shortly after the first one failed, but I’ll push it again now and let you know how it goes
Could you help me understand what it means by “user code server”? Is that referring to the connection to my GitHub repo?
s
Hi Jonathan, the user code server refers to a server that runs your code in our serverless infra to load details about the assets you have defined. I inspected the logs of the user code server and I believe the issue is related to a recent github runner change we have seen and are currently testing a fix. Can you please try the following: In your
.github/workflows/branch_deployments.yaml
, pin the runner to ubuntu-20.04 by setting
runs-on: ubuntu-20.04
. Here's a PR that fixes our quickstart repo for reference.
j
Gotcha, thanks for the update. Trying that change now!
It worked! Thanks for the help dagster yay
j
Glad you were able to get sorted out To answer your other question: https://docs.dagster.io/concepts/code-locations/workspace-files#running-your-own-grpc-server In cloud, we take advantage of this same abstraction to isolate your agent from your actual code. When you add a code location, the agent launches a “user code server” that it can query for metadata about your jobs.
j
Aha, that makes sense. Thanks 👍