# ask-community

Vinu Praveen

02/06/2023, 6:51 AM
Hi Everyone, Im facing the below error while trying to depoy dagster to openshift using azure pipeline. My deployment worked well for a long time but i get this error now. kindly assist :) ImportError: cannot import name '_BindParamClause' from 'sqlalchemy.sql.expression' (/usr/local/lib/python3.7/site-packages/sqlalchemy/sql/
🤖 1
dagster bot responded by community 1

Adam Bloom

02/06/2023, 2:44 PM
If you update to the latest release, that’s resolved. Alternatively, add an explicit dependency to sqlalchemy<2.0.0
They (sqlalchemy) released a major version upgrade and older dagster releases did not have an upper bound on the dependency, so pip is likely installing the new (incompatible) version since nothing is telling it not to

Vinu Praveen

02/07/2023, 5:56 AM
Thanks Adam for the response, could you also let me know if I can add it like below in my docker file? RUN pip install \ dbt-core \ dbt-sqlserver \ dagster==${DAGSTER_VERSION} \ dagster-azure==${DAGSTER_VERSION} \ dagster-postgres==${DAGSTER_VERSION} \ dagster-k8s==${DAGSTER_VERSION} \ dagster-aws==${DAGSTER_VERSION} \ dagster-celery[flower,redis,kubernetes]==${DAGSTER_VERSION} \ dagster-celery-k8s==${DAGSTER_VERSION} \ dagster-gcp==${DAGSTER_VERSION} \ dagster-graphql==${DAGSTER_VERSION} \ dagit==${DAGSTER_VERSION} \ sqlalchemy<2.0.0
yes the above worked with sqlalchemy/<2.0.0. thankyou