I’ve been using a Dockerfile to deploy to Dagster ...
# dagster-plus
I’ve been using a Dockerfile to deploy to Dagster Cloud serverless so that I can use Python 3.10 and a couple other native dependencies. It has been working fine, but while trying to update dependencies today I haven’t been able to get my Docker image to build anymore — it now fails while running
pip install dagster-cloud[serverless]
ModuleNotFoundError: No module named 'poetry'
. I’m not using poetry, so I’m confused. I tried installing poetry into the image, but got the same error. Interestingly, I tried switching back to Python 3.8 and it works fine. Here are the repro Dockerfiles I used to test to be sure. I saw on the dagster-cloud repo that only 3.8 is officially supported, so let me know if this is out of scope, but it is disappointing that it used to build but doesn’t anymore. I’m not confident in my ability to configure python 3.10 on this particular base image (one of my native dependencies prefers
which is why I’m not building off of a python base image) — am I doing that wrong? Is dagster-cloud + 3.10 not guaranteed to work for now? Any recommendations for what I should do?
Hi Jonathan, it looks like this is a dependency introduced in
which relies on poetry. I’m able to get the Dockerfile to build by inserting
Copy code
RUN pip install --no-build-isolation pendulum==2.0.3
Magic 🪄 That does work, thanks!
🙌 glad that fixed it!