# dagster-support

Szymon Piskorz

02/07/2023, 10:03 AM
Hey, I facing a problem when trying to host the equivalent of local development env where I do
dagit -f
onto my vscodeserver that requires to do port forwarding. I have realised that I needed to set the
option, but I am facing some weird issues in the js script that loads the page, it turns blank. The vscode servers puts proxy in rest API path:
that looks like that. Content of page:
Copy code
<!doctype html><html lang="en"><head><meta charset="utf-8"/><meta name="viewport" content="width=device-width,initial-scale=1,shrink-to-fit=no"/><meta name="theme-color" content="#000000"/><script type="application/json" id="initialization-data">{"pathPrefix": "", "telemetryEnabled": "True"}</script><script nonce="d8d9c138a801484fb2602dfbb425fc41">__webpack_nonce__="d8d9c138a801484fb2602dfbb425fc41"</script><link rel="manifest" href="/manifest.json" crossorigin="use-credentials"/><link rel="icon" type="image/png" href="/favicon.png"/><link rel="icon" type="image/svg+xml" href="/favicon.svg"/><title>Dagit</title><script defer="defer" src="/static/js/main.6a14a05a.js" nonce="d8d9c138a801484fb2602dfbb425fc41"></script><link href="/static/css/main.24e9b352.css" rel="stylesheet"></head><body><noscript>You need to enable JavaScript to run this app.</noscript><div id="root"></div></body></html>
Based on limited knowledge of JS it looks like href basepath is not set properly - how do I set it?
After more testing it seems like dagit is adding the prefix by itself and so does the vscodeserver proxy. Is there an option in plans where you could only set the prefix on the static webpage without changing the path of the domain?