https://dagster.io/ logo
#ask-community
Title
# ask-community
y

Yuan Cheng

03/09/2023, 9:00 PM
Hi guys, we are trying to set cron_schedule_timezone for our dbt models, but it is still showing UTC in our dbt model asset: Can you guys help? Thx!
c

chris

03/09/2023, 11:54 PM
Hm I think this is the result of a separate setting. Filed an issue: https://github.com/dagster-io/dagster/issues/12867
y

Yuan Cheng

03/10/2023, 12:21 AM
Hi @chris, for me, the issue only happened for dbt assets, other assets are totally fine.
c

chris

03/10/2023, 12:21 AM
ack - will update issue
y

Yuan Cheng

03/10/2023, 12:24 AM
Thx
Hi @chris, does that mean the setting for dbt is working, it is just not showing correctly on front end?
c

chris

03/10/2023, 12:32 AM
To be honest - not sure which. Waiting for folks on the team who have more experience with the dbt side of things to chime in
y

Yuan Cheng

03/10/2023, 12:32 AM
Sounds good
Hi @chris, just want to follow up to see if there is any update here. Thx
o

owen

03/10/2023, 10:36 PM
Hi @Yuan Cheng! Sorry you ran into this, it was an issue in the code that converts dbt config to FreshnessPolicies (so it was not just a UI issue). It's a simple fix, and will go out in next week's release. If you're interested in resolving this faster, it is possible to pass in a custom
node_info_to_freshness_policy_fn
parameter to your
load_assets_from_dbt...(...)
call. In this case, you could just copy the code from this PR: https://github.com/dagster-io/dagster/pull/12904 🙂 Otherwise, next week's release will have the fix enabled.
y

Yuan Cheng

03/10/2023, 11:33 PM
Hi @owen, thanks a lot!
13 Views