https://dagster.io/ logo
#ask-community
Title
# ask-community
t

Tim Black

04/18/2023, 4:03 PM
Hi all! I'm trying to setup a celery worker config using the guide here. According to the CLI guide, I should be able to start a worker with a custom yaml celery config. I am running the command
dagster-celery worker start -A <http://dagster_celery.app|dagster_celery.app> -y ~/pipeline/celery_config.yaml
with a yaml file like below. The worker starts, but it is still showing the broker address as the default
<amqp://guest>:**@localhost:5672/
instead of the custom one i've specified below. Any idea as to what I'm doing wrong? Thank you in advance!
Copy code
execution:
  config:
    broker: '<pyamqp://celery:celery@localhost/celerymq/>'  # Optional[str]: The URL of the Celery broker
    backend: 'rpc://' # Optional[str]: The URL of the Celery results backend
i figured it out - it looks like the guidance on configuring the executor here is incorrect. The example yaml should be:
Copy code
execution:
  celery:
    broker:
    ..
instead of (what is shown in the docs):
Copy code
execution:
  config:
    broker:
    ..
what is the recommended path for me to help fix the documentation?
o

owen

04/18/2023, 9:47 PM
hi @Tim Black! thanks for digging in, glad you figured it out -- the best option would be to open a PR against dagster-celery
👍 1
12 Views