Do these messages mean there's a network problem w...
# ask-community
Do these messages mean there's a network problem with websockets? I thought I might have been hitting firewall problems, but turns out the same thing shows up at home running dagster dev on localhost. "Disable Websockets" in the settings doesn't affect these, the console keeps logging them every few seconds. This is on Dagster 1.3.1, Chrome browser on Windows 10 and 11
Copy code
client.ts:557 WebSocket connection to '<ws://>' failed: 
e.connect @ client.ts:557
(anonymous) @ client.ts:522
Debug console output doesn't add much
Copy code
WebSocket connection to '<ws://>' ' failed: WebSocket is closed before the connection is established.
Same on Firefox
Copy code
Firefox can't establish a connection to the server at <ws://>. client.ts:557:15
The connection to <ws://> was interrupted while the page was loading. client.ts:557:15
Still learning how to use the dev consoles... the Network>WS tab shows finished attempts every few seconds, but 0 bytes returned. Maybe a bug here? It seems to be falling back on polling fine - I see /graphql calls following up with the fetch method instead of websockets, and those have some bytes returned with status 200.
I tried a few dagster+dagit versions and they all had the same error message in the console 1.3.1 1.0.0 0.15.9 0.14.20 It's actually something about python 3.11 - the same minimal setup with just pip-installed dagster and dagit in python 3.10 seems to work - at least it doesn't show those error messages in the console any more, and the logo mouseover shows a green status circle instead of gray. Logged an issue for it, hopefully that's narrowed things down enough -