# ask-community
Copy code
dagster._core.errors.DagsterUserCodeUnreachableError: Could not reach user code server. gRPC Error code: UNKNOWN

grpc._channel._InactiveRpcError: <_InactiveRpcError of RPC that terminated with:
status = StatusCode.UNKNOWN
details = "Exception calling application: <_InactiveRpcError of RPC that terminated with:
status = StatusCode.RESOURCE_EXHAUSTED
details = "Sent message larger than max (55287749 vs. 50000000)"
debug_error_string = "UNKNOWN:Error received from peer {created_time:"2023-07-21T02:38:00.930692244+00:00", grpc_status:8, grpc_message:"Sent message larger than max (55287749 vs. 50000000)"}"
debug_error_string = "UNKNOWN:Error received from peer {created_time:"2023-07-21T02:38:00.932124373+00:00", grpc_status:2, grpc_message:"Exception calling application: <_InactiveRpcError of RPC that terminated with:\n\tstatus = StatusCode.RESOURCE_EXHAUSTED\n\tdetails = \"Sent message larger than max (55287749 vs. 50000000)\"\n\tdebug_error_string = \"UNKNOWN:Error received from peer {created_time:\"2023-07-21T02:38:00.930692244+00:00\", grpc_status:8, grpc_message:\"Sent message larger than max (55287749 vs. 50000000)\"}\"\n>"}"
Hi, anyone know what happen how to solve this? I'm using docker
This error indicates that something in your definitions snapshot is too large. Do you have an extreme number of jobs/assets ? One possibility is that a piece of metadata you are attaching to something is much larger than you intended.
Hi, this happens when I try to materialize dbt assets (~20 assets). I have larger number of assets from airbyte connection which runs fine (~50 assets). This happen after I update to
. I've tried both
Copy code
dagster api grpc
Copy code
dagster code-server start
with no luck.
1.4.0 had some dbt related bugs, fixes were released in 1.4.1 & 1.4.2. Upgrading likely to solve the issue
@Edo, were you able to solve this? I am getting the same error when trying to materialize a handful of assets (15) in a job.
@Eric Coleman Yes, in my case, it was because of profiles.yml path
Thank you for the reply @Edo. Just curious, was your path incorrect, or was your profiles.yml file missing an entry?
Oh, sorry If I recall correctly this one was not because of the profile path! This was because I use the old
instead of