Hey all - I am looking for some help getting my Da...
# deployment-ecs
Hey all - I am looking for some help getting my Dagster deployment pushed over the finish line. We are building our infrastructure with Terraform and are using ECS Fargate to host dagit and daemon containers along with an Envoy sidecar container. We have an ECS service attached to an internal service discovery service and also created a Route53 record attached to a load balancer with an https listener that routes traffic to the envoy container. We currently have the ECS service, it's task and containers deployed in a healthy state and the load balancer's target group is evaluating as healthy using the
endpoint. When we navigate to the URL, the tab name changes to
and we see a 200 response from
, however, it contains a response of
You need to enable JavaScript to run this app
and all of the JS and CSS responses are returning a 404 status code. I have a diagram of our Terraform deployment available on Miro here and would be happy to share any other files that may help troubleshoot (Terraform modules, ECS task definition, dagster.yaml, etc.) just let me know what is helpful. Thanks in advance for the help
are you using
on your dagit server by chance?
facepalm that was it. We added a prefix to the load balancer's listener rule. When we removed it, we can access dagit as expected. If we decided we wanted to keep the path prefix, how would I configure Dagster for it? Is that an option in the dagster.yml?
Also thank you so much. I've been battling this for weeks. Silly issue, but I'm so glad you spotted it.
its a cli arg to
so you would configure it where you are launching that process then check
<path prefix>/dagit_info
for health instead
Ah gotcha. Thanks again, Alex.