I am new to dagster. I was following <https://docs...
# ask-community
I am new to dagster. I was following https://docs.dagster.io/deployment/guides/kubernetes/deploying-with-helm for setting up dagster. I am facing an issue with AWS s3 io-management. I have aws secrete_key and key_id. But I am getting an error due session token. botocore.exceptions.ClientError: An error occurred (InvalidAccessKeyId) when calling the ListObjects operation: The AWS Access Key Id you provided does not exist in our records. Can someone tell me how to get rid of this error? How to add aws session token in dagster
Hi Anup - this sounds like more of an issue with the key that you're using than a problem with Dagster. AWS has some tips for dealing with this error here: https://aws.amazon.com/premiumsupport/knowledge-center/s3-access-key-error/
@daniel thank you for reply. The problem is solved. Creating kubernetes secrets session token solved the issue 😅.
I am also running into this issue but with using minio, is there anything specific I might be missing? Currently using powershell I have the env vars