https://dagster.io/ logo
#ask-community
Title
# ask-community
j

José Duarte

08/30/2022, 10:51 AM
Hey all, what are the launch plans for
dagster-dbt
v1.0.6? It’s not available in PyPI and I can’t use other versions of it with
dagster
v1.0.6
c

Cameron Gallivan

08/30/2022, 1:35 PM
The integrations aren't on 1.0 status yet,
dagster-dbt
is on version v0.16.6 See the last bullet here: https://github.com/dagster-io/dagster/blob/master/CHANGES.md#other-changes
j

José Duarte

08/30/2022, 1:36 PM
However, 0.16.x library releases remain fully compatible with Dagster 1.x. In the coming months, we will graduate integration libraries one-by-one to the 1.x versioning track as they achieve API maturity. If you have installs of the form:
This would be okay if the package didn’t have strict requirements
j

jamie

08/30/2022, 3:09 PM
hi @José Duarte can you point me to the strict requirements you're referencing? are you getting errors when installing
dagster-dbt
? if so can you share the error message you get?
Copy code
install_requires=[
            "dagster==1.0.6",
            "dagster-pandas==0.16.6",
            "dbt-core",
            "pandas",
            "requests",
            "attrs",
            "agate",
        ],
Poetry is unable to solve the dependencies properly
But let me double-check something
Copy code
[16:12:59] Φ poetry add dagster==1.0.6 dagster-dbt==0.16.6

Updating dependencies
Resolving dependencies... (27.3s)

  SolverProblemError

  Because no versions of prefect match >2,<2.0.1 || >2.0.1,<2.0.2 || >2.0.2,<2.0.3 || >2.0.3,<2.0.4 || >2.0.4,<2.1.0 || >2.1.0,<2.1.1 || >2.1.1,<2.2.0 || >2.2.0,<3
   and prefect (2.0.0) depends on alembic (>=1.7.5), prefect (>=2,<2.0.1 || >2.0.1,<2.0.2 || >2.0.2,<2.0.3 || >2.0.3,<2.0.4 || >2.0.4,<2.1.0 || >2.1.0,<2.1.1 || >2.1.1,<2.2.0 || >2.2.0,<3) requires alembic (>=1.7.5).
  And because prefect (2.0.1) depends on alembic (>=1.7.5)
   and prefect (2.0.2) depends on alembic (>=1.7.5), prefect (>=2,<2.0.3 || >2.0.3,<2.0.4 || >2.0.4,<2.1.0 || >2.1.0,<2.1.1 || >2.1.1,<2.2.0 || >2.2.0,<3) requires alembic (>=1.7.5).
  And because prefect (2.0.3) depends on alembic (>=1.7.5)
   and prefect (2.0.4) depends on alembic (>=1.7.5), prefect (>=2,<2.1.0 || >2.1.0,<2.1.1 || >2.1.1,<2.2.0 || >2.2.0,<3) requires alembic (>=1.7.5).
  And because prefect (2.1.0) depends on alembic (>=1.7.5)
   and prefect (2.1.1) depends on alembic (>=1.7.5), prefect (>=2,<2.2.0 || >2.2.0,<3) requires alembic (>=1.7.5).
  And because prefect (2.2.0) depends on alembic (>=1.7.5)
   and dagster (1.0.6) depends on alembic (>=1.2.1,<1.6.3 || >1.6.3,<1.7.0), dagster (1.0.6) is incompatible with prefect (>=2,<3).
  So, because dystematic.pdbt depends on both prefect (^2) and dagster (1.0.6), version solving failed.

  at ~/.pyenv/versions/3.8.9/lib/python3.8/site-packages/poetry/puzzle/solver.py:241 in _solve
      237│             packages = result.packages
      238│         except OverrideNeeded as e:
      239│             return self.solve_in_compatibility_mode(e.overrides, use_latest=use_latest)
      240│         except SolveFailure as e:
    → 241│             raise SolverProblemError(e)
      242│ 
      243│         results = dict(
      244│             depth_first_search(
      245│                 PackageNode(self._package, packages), aggregate_package_nodes
(.venv) ~/Documents/data/pdbt (master) ✗ 
[16:13:43] Φ
j

jamie

08/30/2022, 3:43 PM
based on the error message this looks more like an issue between dagster and prefect requiring different versions of alembic
j

José Duarte

08/30/2022, 4:21 PM
Ups, that’s my bad then. I was lazy for this test and didn’t create a new venv
let me try on a fresh one
It does seem to work on a clean venv, so the original problem was probably due to the way I declared dependencies
3 Views