Hi, i hope you can point me in the right direction...
# ask-community
Hi, i hope you can point me in the right direction with dagit not starting anymore for some reason: dagit is not starting anymore with multiple workspaces configured in
, it just hangs immediately and nothing happens. I am using multiple
workspaces which worked for me very well before. Now i have the problem that dagit is not starting anymore if there is more than one workspace. I can start dagit with a single workspace and all others commented out. There are 4 workspaces and dagit starts with each of them seperately, so each individual workspace seems not to be the problem. But dagit will only start if there is only one workspace at all. Also, if i start dagit with just one workspace in the file, then comment in the others and then reload the workspaces via button in the already running dagit instance that also works fine. I already tried to set log-level to trace, but dagit is not logging anything when it hangs in startup with multiple workspaces, it just gets stuck immediately. I am running dagit inside a docker container with verion 0.15.8 but also tried 0.15.7 and 0.15.6. I hope you have some idea what i can try to figure out what the problem is because i am not aware of any changes i made that might have lead to that.
🤖 1
If i configure two workspaces and put nothing but an empty
and a
inside i can see the print from the first but not from the second workspace configured in
. So seems like dagit hang starts before or while loading the second workspace.
Hi Mark - could you try installing dagster with grpcio 0.14.7 and see if that helps? Some people ran into a similar issue due to some bugs in the most recent grpcio release here: https://github.com/dagster-io/dagster/issues/9099
And also https://github.com/grpc/grpc/issues/30446 has some similar symptoms
Downgrading to grpcio 1.47.0 did it, dagit ist starting with multiple workspaces again, thanks so much Daniel!
❤️ 1