https://dagster.io/ logo
#ask-community
Title
# ask-community
e

Eliott Bigiaoui

01/13/2023, 4:48 PM
Hi all! I need to use some Pyminizip, a package that requires gcc, but it is not pre-installed in the python3.8:slim version that is run by default. I tried to install gcc as a step in the .github/workflows/*.yml files (just before the step named
Build and deploy to Dagster Cloud serverless
):
Copy code
- name: Install gcc
  run: sudo apt-get update && sudo apt purge gcc -y && sudo apt-get install gcc -y && sudo apt-get clean
But it seems that this is not effective and I still get this error during the next step:
Copy code
gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -fPIC -Isrc -Izlib-1.2.11 -Izlib-1.2.11/contrib/minizip -I/usr/local/include/python3.8 -c src/py_minizip.c -o build/temp.linux-x86_64-3.8/src/py_minizip.o
unable to execute 'gcc': No such file or directory
error: command 'gcc' failed with exit status 1
Do you have any idea how I could install it? (Would changing the Python version allow me to use something different than Python:slim?) Thanks!
cc @Kevin Martin
d

daniel

01/13/2023, 4:56 PM
Hey Eliott - you can also specify a different base image, instructions for how to do that are described here: https://docs.dagster.io/dagster-cloud/deployment/serverless#using-a-different-base-image-or-using-native-dependencies
1
e

Eliott Bigiaoui

01/13/2023, 7:02 PM
Thanks! I just changed the base image here:
Copy code
- name: Build and deploy to Dagster Cloud serverless
        uses: dagster-io/dagster-cloud-action/actions/serverless_branch_deploy@v0.1
        with:
          dagster_cloud_api_token: ${{ secrets.DAGSTER_CLOUD_API_TOKEN }}
          location: ${{ toJson(matrix.location) }}
          base_image: "python:3.8-bullseye"
condagster 1