I’m hitting the following error when I run `pip in...
# ask-community
I’m hitting the following error when I run
pip install -e ".[dev]"
from the README in the project scaffold… Seems related to the
dependency but I can’t figure out how to resolve
Copy code
(dagster-course) timdenengelsen 16:48 ~/playground/dagster_playground/dagster-course/dagster $ pip --version
pip 22.3.1 from /Users/timdenengelsen/playground/dagster_playground/dagster-course/lib/python3.9/site-packages/pip (python 3.9)
Are you on an m1 mac by any chance? A lot of install errors we see happen as a result of being on an m1 mac, and looks like there might be some m1 related incompatibilities: https://stackoverflow.com/questions/71443345/gevent-cant-be-installed-on-m1-mac-using-poetry
I’m not unfortunately… I’m also seeing this error on line 440 of my snippet
error: command '/usr/bin/clang' failed with exit code 1
I’ve tried a bunch of things like running
pip install --upgrade pip
pip install --upgrade setuptools
export CFLAGS='-stdlib=libc++'
I’ve also tried with using different versions of python in my environment 3.9, 3.10, and 3.11 and all get the same error
hrm super weird - going to forward this to the team, see if anyone has experienced something similar
👍 1