https://dagster.io/ logo
#integration-dbt
Title
# integration-dbt
g

geoHeil

02/17/2023, 6:12 PM
Is DBT 1.4.1 already supported?
o

owen

02/17/2023, 6:28 PM
hi @geoHeil yep the dagster-dbt integration should support the latest version of dbt
g

geoHeil

02/17/2023, 6:47 PM
Interesting
File "/site-packages/dbt/adapters/postgres/__init__.py", line 4, in <module> E from dbt.adapters.postgres.relation import PostgresColumn # noqa E File "/site-packages/dbt/adapters/postgres/relation.py", line 4, in <module> E from dbt.exceptions import DbtRuntimeError E ImportError: cannot import name 'DbtRuntimeError' from 'dbt.exceptions'
when paired with dbt-postgres something was forcing inconsistent dbt versions
Even when forcing dbt-postgres and dbt-core to be 1.4.1
I will have to double check the transitive dependency tree then 😢
@owen dbt-core==1.3.2 - dagster-dbt==0.17.14 [requires: dbt-core<1.4.0] - MWF==0.0.80.dev0 [requires: dagster-dbt==0.17.14] - dbt-postgres==1.4.1 [requires: dbt-core==1.4.1] - sqlfluff-templater-dbt==1.4.5 [requires: dbt-core>=0.20.0]
Something is giving me 1.3.2 - I do not understand what. However, dagster-dbt only seems to support 1.4.0 and not 1.4.1
Strange - even when using 1.4.0 something is forcing 1.3.2
o

owen

02/17/2023, 7:14 PM
ah there was an incompatibility issue with dagster-dbt and dbt-core 1.4 when dbt first bumped the library version. So for a release or two, we had dbt-core pinned to <1.4. That's since been fixed, so if you update to the latest version of dagster, then this pin will go away
g

geoHeil

02/17/2023, 7:17 PM
I tried with: 0.17.19 - and this is the latest one as far as I know
o

owen

02/17/2023, 7:28 PM
hm in the message above you had
dagster-dbt==0.17.14 [requires: dbt-core<1.4.0]
-- what does your
pip freeze
look like at the moment?
g

geoHeil

02/17/2023, 7:54 PM
you were right - I overlooked one occurence of it --- mixup of conda and setup.py 😢
thx for the reminder
18 Views